Home Forums Digital DJ Gear Denon MC4000 issues

This topic contains 4 replies, has 3 voices, and was last updated by  DJ Hombre 2 years, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2482541

    DJ Hombre
    Blocked

    Hi all,
    Hope you’re good. Just wondering if there are any other Denon MC4000 users out there? I’ve had mine since new (a month or so ago). I’ve hooked it up to my iPad using a powered USB hub & mapped it nicely to a lot of the functions in DJ Player Pro. So far, so good. In fact, a casual play here & there, everything is brilliant. Even the VU’s!

    However, I attempted my first proper mix session on it yesterday & had all sorts of random issues. It felt like the unit was sending mixed midi messages to the app. For example, I was blending between 2 tracks, moving the crossfader slowly across & nudging one track then suddenly both tracks would bounce back to cue 1 and play from there. Another time I had FX 1 engaged & decided to adjust the low EQ and suddenly the FX switched off by itself or engaged another FX.

    I’ve done a little searching around & there seem to be a few folk using Serato with similar midi issues. I’ve logged it with Denon support, so fingers crossed.

    Just wondering if anyone else has experienced this weird behaviour on their unit?

    Btw – iPad is in flight mode & no other apps running. MC 4000 shipped with latest firmware installed.

    #2482771

    DJ Tucker
    Participant

    I had the exact same experience with the 4000 on my MBP using both VDJ8 and Djay Pro. I loved this unit. It sounded great, worked great, felt great… It was going to be the last controller I ever bought. Originally, I had the first unit I bought (day one as soon as it was in stock) fixed under warranty. That made it worse by actually breaking something else, so I talked them into sending me a new unit. My gig at the time was a 4-hour gig and randomly during my next gig, same mixed midi issues as you describe. I dumped it on eBay and moved on. Shame.

    #2482791

    Zachary Brasseaux
    Participant

    I’ve had mine for over a year and never had any issues that could be tied back to the controller. There was one instance where it didn’t want to play nice with the new drive I installed, so I just swapped it back to the old HDD until after the gig, but that’s the only problem I’ve had, *knocks on wood.*

    #2483611

    DJ Hombre
    Blocked

    I’ve mapped & remapped this unit – much to my family’s amusement. I think the issue is caused by the unit dealing with incoming midi messages – in order to light up the LEDs. Switch all the LED midi messages off & the unit works fine, just a little dull / difficult to use – especially in a club!

    I’m gradually switching the LEDs back on, but it takes time & you need to retest after each setting! Hopefully Denon can impart some wisdom.

    #2484211

    DJ Hombre
    Blocked

    It’s tantalisingly close to working, so I’m not gonna give up just yet. Denon have suggested it could be a power issue – I’m on an iPad 3 so don’t have the luxury of the nice new USB 3 A camera adapter which provides power & charges the IPad too.

    Probably a cautionary tale to us all, just because something’s USB class compliant doesn’t necessarily mean it’ll sail through without issue on iOS.

    Still a great unit though, I just need to nail this Gremlin!

Viewing 5 posts - 1 through 5 (of 5 total)

The forum ‘Digital DJ Gear’ is closed to new topics and replies.