Home Forums DJing Software No Volume Control – Traktor Pro 2

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2433851
    Geoffrey Hinds
    Participant

    Hello,
    I’d been using Traktor Pro 2 with a Denon MC6000MK1 and MacBook Pro without issue for 2 years. I installed an iTunes update (the one before last) and all of a sudden no sound. Checked everything. Even tried using a mac desktop with pro 2 on it. Nothing. Assumed it was a hardware issue and I took the MK1 for repair. When I got it home, I got sound but could only control it from the master volume. Slides and cross fader didn’t work. Then I thought it was a hardware issue. MK1 was discontinued so I took the plunge and ipgraded to MK2 when I saw Traktor mapping was available. Installed new Mapping, plug in MK2, same deal. Volume controlled only with master, no slides or cross fader. Installed Serato, which came with MK2 and it worked flawlessly. I don’t mind exploring Serato as its good to be as well rounded as possible. However, I prefer Traktor and was really getting into it. (I enrolled ddt’s Traktor course–fantastic!) One more thing, I set up preferences as suggested: (Yes) External controller (no) External Mixer and the rest. No sound at all in that config. When I said yes to external mixer I got the uncontrolled volume I described earlier. Any suggestions would be greatly appreciated.
    Geof

    #2434001
    DJ Vintage
    Moderator

    In external mixer mode Traktor will send the sound to (if set up correctly) your controller as track 1 and track 2. Your controllers mixers will then have to do everything else, including master volume.

    In internal mixer mode Traktor will send the master output from the software to the master output of your controller and the cue signal to the headphone output.

    You will have to set what deck sound goes to what bit of sound card channels in external mixer mode.

    #2434051
    Geoffrey Hinds
    Participant

    DJ Vintage,

    Thank you so much for your incredibly prompt reply. I went with external mixer because internal kills the audio. I get the red over the audio icon in traktor.

    That’s the problem for me. Traktor does not seem to be sending the sound to tracks 1 & 2. That’s the functionality I’m looking for. In preferences, for both input and output, I have marked all deck options (A/B/C/D) as front left/front right. Am I missing something?

    Thanks,
    Geof

    #2434801
    DJ Vintage
    Moderator

    Been years since I used Traktor, so bit rusty on the settings.

    1) Pick the right audio device (driver) on the Audio Setup tab under “Audio Device” (duh!). This should probably be the Denon DJ ASIO Driver if I recall correctly (at least it was with my MC6000 I think).
    2) On the Output Routing tab, select “External” for Mixing Mode (as you have).
    3) Now set Output Deck A to (for example) channel 1 L and channel 1 R or Front L and Front R. You should have 4 options (or even more if you use a higher channel count sound card, but generally it will be 4 for a controller like the MC6000)
    4) Set Output Deck B to something different! It could be marked as channel 2 L + R or Back L + R.

    If you have only 1 set (of stereo, thus L + R) of options, like you describe with front left/front right, something is wrong. Either the wrong device selected or the wrong device driver (not) installed. Probably the right driver can be found at the Denon site. You can also try the ASIO4All drivers from their site.

    But you should have the option to choose from 4 (2 x a L+R combo), otherwise it won’t work properly.

    #2435651
    Phill Renyard
    Participant

    If you’re sure you’ve got the correct audio device set and you’re only seeing 2 stereo outputs (I’m guessing front left/right and back left/right) then you would need to select internal mixer mode and the outputs as Output master and output monitor(for the headphones). Also check the mapping is correct and working because it sounds to me like this could be your problem – check that the correct mapping is active in the controller manager and that the in port and out port are showing as the correct device. If it still doesn’t work the mapping might be at fault – I would suggest you download the mapping again if this is the case.

    I hope you find this helpful.

    #2436341
    Geoffrey Hinds
    Participant

    Phillip,

    I made sure I had the right map, did the set up (external controller, internal mixer). I putzed around with the output monitor (back left/right) and output master (front left/right) and its now working perfectly. Thank you for rescuing me from 2 weeks of hell. I bet my old MC6000MK1 will work perfectly with that setting. However, it cool to have 2 new toys! Not only do I have a hopped up new controller but I get to play with Serato DJ as well.

    I just don’t understand why it stopped working with the external controller, external mixer settings. Weird! Again, my thanks!

    Best,
    Geoff

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘DJing Software’ is closed to new topics and replies.